WOL sort of works - but

Control the state of remote PCs. [link]
Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
adacom
Posts: 5
Joined: Sun Feb 20, 2011 11:53 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

WOL sort of works - but

Post by adacom » Sun Feb 20, 2011 12:01 pm

running 64bit windows 7 - that may be part of the problem - if i press the 'wake up' button for another computer on the network - it may wake up the computer - then again it may not - there is no pattern

however if i press the 'wake up' button a few times in quick succession the remote computer wakes up 100% of the times i have done that

i assume i am sending the wake up command on each press to creating a longer stream which works - is there any way to increase the number of packets sent on one press to make things easier and work every time

or alternatively could it be done through a custom action

adacom
Posts: 5
Joined: Sun Feb 20, 2011 11:53 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: WOL sort of works - but

Post by adacom » Tue Mar 29, 2011 1:20 pm

is this product still supported - i note the writer has posted on the site but not much lately - its a good product but some help would be appreciated

User avatar
BootBlock
Unclean, unclean!
Posts: 425
Joined: Wed May 28, 2008 11:17 pm
Location: United Kingdom
Contact:

Re: WOL sort of works - but

Post by BootBlock » Sun Apr 03, 2011 10:33 am

Hi adacom,

sorry about not responding to your support request sooner - I'm having a bit of a problem with my network.

I've been unable to use WoLEX myself as all wake-up functionality on the network ceased to function over a year ago; can't really work out why as nothing changed. Nothing changed in WoLEX either - and I tested other wake-up apps to ensure it just wasn't WoLEX, but they don't work either.

Because of this, I haven't been able to investigate bug reports (albeit quite rare) on WoLEX sometimes not waking-up devices, and also haven't done any core development work on it.

I had another attempt at trouble-shooting the network before replying to your post, but I still can't pinpoint where the failure is.

I'm not entirely sure what the state the code is in (I may have worked on it and then moved onto something else due to getting frustrated with not being able to truly test it, so the code could have loose ends that I'm now unaware of), but I could do a blind update that allows you to send longer packets.

adacom
Posts: 5
Joined: Sun Feb 20, 2011 11:53 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: WOL sort of works - but

Post by adacom » Sun Apr 03, 2011 10:49 am

ahhhh networks - nothing has changed over the years really - its all still a black art

i have got the program working pretty well - i use it to wake up 2 computers - one works exactly as it should - the other takes 3 or 4 presses of the wake up button - different systems - different network cards so sure thats the problem - but a feature to send one or more packet streams would be useful - maybe it could be a setting - that would certainly solve it

or even a custom action

User avatar
BootBlock
Unclean, unclean!
Posts: 425
Joined: Wed May 28, 2008 11:17 pm
Location: United Kingdom
Contact:

Re: WOL sort of works - but

Post by BootBlock » Sat Aug 27, 2011 8:12 pm

Just a little update to let you know that I haven't forgotten about this.

I've tried a huge amount of testing but I still cannot get my other PC waking up (it's connected directly to this development PC and not through a router), but in the meantime I've resumed work on the next version of WoLEX. I've added the option of sending a wake-up multiple times (default is six, but can be changed if required) - see attached screenshot - and I'm currently going through this WoLEX forum to add other features.

I've re-written the wake-up code, but as my current setup is incapable of being woken up, it's impossible to test to see if it actually works. Seems I might have to release a little console app as a tester...

Image

adacom
Posts: 5
Joined: Sun Feb 20, 2011 11:53 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: WOL sort of works - but

Post by adacom » Sun Aug 28, 2011 9:35 am

thats interesting - let me know if i can help in testing

User avatar
BootBlock
Unclean, unclean!
Posts: 425
Joined: Wed May 28, 2008 11:17 pm
Location: United Kingdom
Contact:

Re: WOL sort of works - but

Post by BootBlock » Sun Aug 28, 2011 11:31 am

Hi adacom,

I've just finished the test console app. If you're willing to give it a try (and anyone else reading, for that matter), you can run it from a command prompt (so it doesn't auto-close on you) and it'll give you some information on what to do. Basically, you pass it the MAC-ID of the remote device you want to wake-up, and optionally, a port number and the number of times you want it to send the wake-up event.

The main thing to test is just giving it a MAC-ID and leaving the other values at their defaults to see if it works.

Thanks!

Download: WoLEX Pro Test v0.95 (6KB; requires .NET Framework 4.0)

adacom
Posts: 5
Joined: Sun Feb 20, 2011 11:53 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: WOL sort of works - but

Post by adacom » Sun Aug 28, 2011 1:13 pm

will look at that - just redone my network after a router problem and a few things need sorting before i try it but will get back asap

EDIT

works fine - just added the MAC address as you said - did not alter anything else and started remote PC - tried it a few times and no problems

some suggestions - if its possible to add

it takes the remote PC's i start about 2 minutes to be up and running - it would be nice if there was an automatic way of knowing they had started - i do it now by pinging them - i run a script from your config menu for each PC - would it be possible for the program to run this every 10 sec or so until it got a response that the server had started - the .vbs file i run is below - i have no idea what it does apart from ping the computer - i will have found it somewhere on the net



On Error Resume Next
Dim strTarget, strPingResults
strTarget = "192.168.1.66" 'IP address or hostname
Set WshShell = WScript.CreateObject("WScript.Shell")
Set WshExec = WshShell.Exec("ping -n 2 -w 500 " & strTarget) 'send 2 echo requests, waiting .5secs each
strPingResults = LCase(WshExec.StdOut.ReadAll)
If InStr(strPingResults, "reply from") Then
WScript.Echo "Backup Server is running."
Else
WScript.Echo " Backup server is offline."
End If

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 0 guests