Wake on Lan EX 2 Rocks.... But...

Control the state of remote PCs. [link]
kalu
Posts: 6
Joined: Thu Nov 12, 2009 11:49 am

Wake on Lan EX 2 Rocks.... But...

Post by kalu » Thu Nov 12, 2009 12:04 pm

Greetings to everyone...
wake on Lan Ex2's all feature is not working for me.
Only WakeUP feature is working but "logoff" shutdown" "send message" are not working.
Is it necessary to have .NET FRAME WORK on all PC's, to use this feature.. i don't think so..
Please correct me if i'm wrong..
which feature of windows does wake on lan ex2 use to send message is it net send (windows messengers) or msg ?? or it has some built in engine.
i have proper a/c on the remote machine but yet, the "logoff" "shutdown" "restart" "message" function is not working.
could any one please guide me what should i do ??
Thanks in advance
Kalu

User avatar
BootBlock
Unclean, unclean!
Posts: 425
Joined: Wed May 28, 2008 11:17 pm
Location: United Kingdom
Contact:

Re: Wake on Lan EX 2 Rocks.... But...

Post by BootBlock » Thu Nov 12, 2009 12:40 pm

Hey kalu,
Is it necessary to have .NET FRAME WORK on all PC's, to use this feature.. i don't think so..
Like you say, the .NET Framework isn't required on the remote machines. It just needs to be installed on the PC that's running WoLEX.
which feature of windows does wake on lan ex2 use to send message is it net send (windows messengers) or msg ?? or it has some built in engine.
WoLEX has two options available for sending a message to another PC. The first method is NetSend. This, as you can guess, uses the Windows NET command for sending messages.

The second is MailSlot, which uses the Windows Mailslot messaging API for sending messages. The Mailslot API is what NET SEND internally uses itself. As far as I know, neither of these methods are available on Windows Vista or 7.
i have proper a/c on the remote machine but yet, the "logoff" "shutdown" "restart" "message" function is not working.
If I remember correctly (I lasted looked into this when I wrote the original version of WoLEX), you had to be "authenticated" on the remote machine before you could send it commands. A good way of doing this is to access a shared folder on that machine.

Your PC will also need to be either in the same Domain or Workgroup as the remote PC. If it isn't, then it is likely this is your problem and you may not need to authenticate yourself via a shared folder as above.

kalu
Posts: 6
Joined: Thu Nov 12, 2009 11:49 am

Re: Wake on Lan EX 2 Rocks.... But...

Post by kalu » Fri Nov 13, 2009 7:10 am

If remember correctly (I lasted looked into this when I wrote the original version of WoLEX), you had to be "authenticated" on the remote machine before you could send it commands. A good way of doing this is to access a shared folder on that machine.
Well... thankyou verymuch BootBlock
i logged in to remote PC with remote desktop (mstsc) and i tried sending message
...BANG.. the message came
and i tried to shutdown,logoff,restart but none of them worked.. is using remote desktop not equivalent to being "authenticated" do i really have to access the share of each and every pc that i want to logoff,restart,and shutdown.

Thanks for the prompt reply
kalu

User avatar
BootBlock
Unclean, unclean!
Posts: 425
Joined: Wed May 28, 2008 11:17 pm
Location: United Kingdom
Contact:

Re: Wake on Lan EX 2 Rocks.... But...

Post by BootBlock » Fri Nov 13, 2009 10:43 am

What I've been reading is that your PC and the remote PC needs to be in the same workgroup, and I've read in some places that your username/password on your PC needs to match the username/password on the remote PC. Is this true in both cases?

If yes, then try accessing one share of a remote PC and see if that allows you to shut it down, as a test.

I might be able to change the username/password requirement if I use a different method of controlling the other PC than the built-in Windows one. But this means the entry for each device in the address book would require Username/Password fields (which would be stored in an encrypted state on disk).

kalu
Posts: 6
Joined: Thu Nov 12, 2009 11:49 am

Re: Wake on Lan EX 2 Rocks.... But...

Post by kalu » Mon Nov 16, 2009 11:41 am

okay Thankyou BootBlock
Now i got you correctly
thanks once again
kalu

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests